ALGORITHMIQUE 1 : PRINCIPE

1. Principe de l'algorithmique
Un ALGORITHME est une suite d'instructions,qui une fois exécutée correctement, quelque soit le langage, conduit à un résultat donné.
Si l'algorithme est juste, le résultat obtenu le sera. Sinon le résultat peut devenir, disons aléatoire.
En informatique, on a la chance de savoir d'emblée que l'ordinateur est un IDIOT, à qui il est nécessaire de TOUT DEFINIR et DIRE, pour qu'il soit capable d'obtenir le résultat attendu.

Pour écrire un bon algorithme, il faut être méthodique et rigoureux. Chaque fois qu'on écrit une série d'instructions qu'on croit juste, il faut systématiquement se mettre mentalement à la place de la machine qui va les exécuter.
Les briques de l'algorithmique
Boucle "Tant que" Boucle "Pour" Instruction conditionnelle "Si...Sinon" Structure "Selon que..."
                                
x : entier ;
x ← 1 ;
Tant que (x ≤ 5) faire :
    x ← x + 1;
Fait
                                
                            
                                    
x : entier ;
Pour x de 0 à 5 faire :
    x ← x + 1;
Fin Pour
                                    
                                
                                    
x : entier ;
x ← 0 ;
Si (x = 0) Alors :
    x ← 1;
Sinon 
    x ← 2;
Fin Si
                                    
                                
                                
x : entier ;
x ← 0 ;
Selon que :
    x = 0 : x ← 1 ;
    x = 1 : x ← 11 ;
    x = 2 : x ← 111;
Fin Selon que
                                
                            
Exemples
                        
x : entier ;
x ← 0 ;
Tant que (x < 1 ou x > 3) faire :
    x ← entrée de l'utilisateur
Fait
                        
                    

                        
nb : entier ;
x ← entrée de l'utilisateur
Pour x de nb à (nb + 10) faire :
    Afficher x
Fin Pour
                        
                    
2. Préconditions et Postconditions